Symptom
•'Test All' on server tab reports warning that 'Authentication URL' contains HTTPS
•Phone Screen not displaying and reports Error 4
Cause
•A hostname exists in the Phone's Authentication URL but no DNS has been configured. For example: http://CUCMX:8080/ccmcip/authenticate.jsp. CUCMx is the hostname. CUCMx must resolve to the CUCM IP on all phones.
NOTE: If the hostname does resolve to an IP address on your phones and within the network, this is a legitimate configuration and the Phone Control Tool will work. This message is a Warning and not an error but Phone Control tool cannot ascertain this.
Verification
Check the Authentication URL on the phone (Please see Check Phone Configuration). The Authentication URL must comply with the following:
•If a Hostname (not an IP address) is used, make sure the DNS entries are correct so that the Phone can resolve the Hostname.
Resolution
•Set the field CUCM Enterprise Parameters > Secure Authentication URL to empty. This requires a restart of all phones to write the value to the phone. Verify on the phone's web page as seen on below screenshot.
•Check the DNS entries of the phone are correct and that the Hostname used exists in the DNS.
•Add the Hostname to the DNS server or add the DNS server to the DHCP server and reboot the phone to obtain a new IP Address with options.
There is no direct way to check that a phone can resolve a DNS name but there is useful information in the log files that can help ascertain it.
|